We’re happy to share that our systems have fully recovered, and WiseStamp is now operating as usual. All services, including signature processing, page load times, and sign-in functionality, are back to normal.
We sincerely apologize for any inconvenience this temporary disruption may have caused and truly appreciate your patience and understanding while our team worked to resolve it.
If you encounter any issues, please don’t hesitate to reach out to our Support team via the chat widget on the bottom right of the page. Thank you for being part of the WiseStamp community!
Posted Nov 12, 2025 - 19:22 UTC
Investigating
We are currently experiencing a temporary degraded performance in our processing systems, which may cause some customers to experience missing or delayed email signatures, slow page load times, or difficulty signing into the WiseStamp web application. Please note that this issue does not impact your ability to send emails — all emails are being sent successfully.
Our engineering team is actively investigating and working to restore full functionality as quickly as possible. We’ll continue to provide updates here as more information becomes available.
If you have any questions, please feel free to contact our Support team via the chat widget on the bottom right of the page. Thank you for your patience and understanding.
Posted Nov 12, 2025 - 16:18 UTC
This incident affected: Management Platform (General Access) and Signatures Embedding - Email Clients (Outlook Add-in (Microsoft), Gmail Integration (Google)).